Функции даты и времени MS Excel 


Мы поможем в написании ваших работ!



ЗНАЕТЕ ЛИ ВЫ?

Функции даты и времени MS Excel



Задание.

 

В ячейку A1 введите следующую формулу, которая при помощи функции СЕГОДНЯ отображает текущую дату: ="Сегодня:"&ТЕКСТ(СЕГОДНЯ();"ДД ММММ ГГГГ"). В ячейку A2:A4 введите текст по образцу (см. рис.). В ячейки введите числа, которые соответствуют сегодняшнему дню, месяцу, году.

 

Для того чтобы из года (ячейка В2), месяца (ячейка ВЗ) и дня (ячейка В4) собрать дату, введите в ячейку В5 формулу =ДАТА(В2;ВЗ;В4) (Окно: Аргументы функции).

А чтобы из даты (ячейка В5) извлечь год, месяц и день, в ячейки В6, В7 и В8 введите соответственно следующие формулы: =Год:"&ГОД(В5), ="Месяц:"&МЕСЯЦ(В5), ="День:"&ДЕНЬ(В5).

 

Введите в ячейки C1 и С2 текст, а в ячейки D1 и D2 даты, выделив эти ячейки и измените тип данных. Для этого: Формат ячеек – Число – Дата – ЧЧ.ММ.ГГГГ (14.03.2001).

 

Предположим, вам надо посчитать продолжительность работы в днях между начальной (ячейка D1) и конечной датами (ячейка D2). Для этого можно ввести в ячейку D3 формулу =D2-D1+1. Но ведь нам надо знать количество дней в числовом формате. Тогда формула должна быть вот такой: =ТЕКСТ(D2-D1+1;"≠≠≠"). Здесь мы применяем автоматическое форматирование. А если мы хотим узнать, каким по порядку днем года является данная дата (ячейка D4) (см. как в образце)? Очень просто: в ячейку D5 введите формулу =D4-ДАТА(ГОД(04);1;0), которая находит разность между данной датой и 1 января того же года. В результате может получиться значение в виде даты, выделив ячейку D5 переведем в числовой формат. Формат – Ячеек – Число – Числовой тип и Знаков после запятой – 0.

 

Или вот такая задача: определить, является ли данная дата (ячейка D4) субботой или воскресеньем? Введите в ячейку D6 следующую формулу: =ЕСЛИ(ИЛИ(ДЕНЫНЕД (D4;2)=6;ДЕНЬНЕД(D4;2)=7);"Суббота или Воскресенье";””). В ней применена функция ДЕНЬНЕД, которая возвращает номер дня недели заданной даты. Если указанная дата попала на субботу или воскресенье, то именно это и будет указано в ячейке, если нет, то не будет указано ничего.

 

Для определения текущего времени надо из текущих даты и времени, возвращаемых в числовом формате функцией ТДАТА, вычесть текущую дату (функция СЕГОДНЯ), а результат (ячейка В11) перевести в формат времени: =ТЕКСТ(ТДАТА()-СЕГОДНЯ();"ЧЧ:ММ:СС").

 

Введите в ячейки B12, B13, B14 значения часов, минут и секунд в соответствии с образцом (см. рис.). Чтобы из часов (В12), минут (В13) и секунд (В14) «собрать» время, введите в ячейку В15 формулу =ВРЕМЯ (В12;В13;В14). В ячейки A17 – A19, B17 – B19 введите данные в соответствии с образцом. А чтобы найти суммарный промежуток времени (В17, В18, В19), в ячейку В20 введите формулу =СУММ(В17:В19). Если суммарный промежуток времени, как для данных из диапазона D17:D19, больше 24 часов, то простого суммирования будет недостаточно. В этом случае результат надо отформатировать (D20), причем часовую составляющую заключить в квадратные скобки, как это сделано в формуле =ТЕКСТ(СУММ (D17:D19);“[Ч]:ММ”).

Форматирование ячеек в табличном процессоре Excel

Допустим мы создаем бланк:

Форматирование ячеек включает в себя:

Изменение ширины столбцов:

Вручную; Автоподбор; Клавиши – Alt + Enter

Выбор ширины и выравнивание текста.

Выбрать шрифт, начертания; Объединять ячейки; Выровнять текст

Форматирование чисел.

В контекстном меню диалоговом окне щелкните мышью на ярлычке с надписью Число, в списке Числовые форматы выберите формат Денежный.

Если много 000 Выделенные суммы отобразятся с разделением тысяч и символом «р.»

Обрамление и фон ячеек.

подчеркивание заголовков и выделение цветом

контекстное меню – формат ячеек

Изменение информации в бланке..

Подготовка документа к печати всегда должна начинаться с установки параметров страниц.

• Выберите команду меню Файл - Параметры страницы. Появится диалоговое окно.

• Выберите вкладку Страница. Установите опцию Книжная в поле Ориентация.

• Откройте список Размер бумаги и выберите строку А4 210*297 мм.

• Выберите вкладку Поля. Установите желаемые отступы от краев листа бумаги с помощью полей Верхнее, Нижнее, Левое, Правое или оставьте прежние..

• Выберите вкладку Колонтитулы. Колонтитулы - это первая и последняя строки документа, которые используются для размещения служебной информации: номеров страниц, названия документа, даты его создания и т. д.

 

Моделирование в среде табличного процессора MS Excel

Задача. Моделирование биологических процессов (Биоритмов).

Цель моделирования: На основе анализа индивидуальных биоритмов прогнозировать неблагоприятные дни, выбирать благоприятные дни для разного рода деятельности.

Технология выполнения работы:

Объединить A, B, C, D - Моделирование биоритмов человека

Объединить третью строку A, B, C, D - Исходные данные.

Объединить А4 и В4, ввести текст - Неуправляемые параметры (константы).

Объединить С4, D4, ввести текст - Управляемые параметры.

А5 - Период физического цикла.

А6 -Период эмоционального цикла.

А7- Период интеллектуального цикла

В ячейках В5, В6, В7 проставить соответственно числа: 23, 28, 33

C5 - Дата рождения человека.

C6 – Дата отсчета.

C7 – Длительность прогноза

Заполните ячейки D5, D6, D7 соотв-но – свою дату рождения, дату отсчета - 1.10.04, длительность прогноза - 31

Объединить ячейки А8, В8, C8, D8 и напечатать текст: Результаты

В А9 – текст: Порядковый день. В В9 – текст: Физическое. В С9 – текст: Эмоциональное. В D9 – текст: Интеллектуальное.

В ячейку А10 введите дату отсчета. Например: 1.10.04

В ячейку В10 введите формулу: =SIN(2*ПИ()*(A10-$D$5)/23)

В ячейку С10 введите формулу: = SIN(2*ПИ()*(A10-$D$5)/28)

В ячейку D10 введите формулу: = SIN(2*ПИ()*(A10-$D$5)/33)

Сохранить файл под именем Bio.xls

 



Поделиться:


Последнее изменение этой страницы: 2016-04-07; просмотров: 453; Нарушение авторского права страницы; Мы поможем в написании вашей работы!

infopedia.su Все материалы представленные на сайте исключительно с целью ознакомления читателями и не преследуют коммерческих целей или нарушение авторских прав. Обратная связь - 44.197.231.211 (0.009 с.)