ТОП 10:

Функции в EXCEL. Обработка массивов



Цель работы:Изучить:

· Функции в Excel.

· Обработка массивов.

 

Теоретическая часть

 
 

Функции вводят в таблицу в составе формул либо отдельно. В Excel различают функции следующих видов: математические, логические, статистические, финансовые, функции даты и времени и другие. Все функции имеют одинаковый формат записи и включают имя функции и находящийся в круглых скобках перечень аргументов, разделенных запятыми (рис. 13). При вводе функций удобно пользоваться Мастером функций, вызываемым кнопкой Вставка функций, расположенной на панели инструментов Формулы (рис. 14).

Рис. 13. Ввод функций

Рис. 14. Мастер функций

 

Если окно Мастера функций перекрывает нужные ячейки, перетащите его в другое место.

Математические функции (рис. 15) выполняют различные математические операции, например, вычисление логарифмов, тригонометрических функций, преобразование радиан в градусы, возведение в степень и другие. Одной из распространенных математических функций является суммирование – СУММ.

Рис. 15. Математические функции

Пример. Задать в столбце А со 2-ой по 6-ю строку произвольные числа. Найти их сумму в ячейке А7. Для этого, установив курсор в ячейку А7, следует вызвать Мастер формул. В открывшемся окне в списке категория выбрать Математические и нажать кнопку ОК. В текстовом поле Число, следует указать диапазон ячеек, выделив в таблице соответствующие ячейки. Ввод формулы завершается нажатием клавиши ОК. Готовая формула должна иметь вид:

= СУММ(А2:А6).

Проверьте правильность ответа. Выполните этот же пример, пользуясь кнопкой «автосуммирование» на панели инструментов.

Логические функции используются для построения логических выражений, результат которых зависит от истинности проверяемого условия. К логическим функциям Excel относится функция ЕСЛИ. Она определяет выполняемую логическую проверку. Формат:

ЕСЛИ (логическое выражение; значение, если истина; значение, если ложь).

Пример. Открыть новый лист. Задать в ячейках А1 и В1 произвольные числа. Если число А1 больше числа В1, в ячейке С1 напечатать их разность. Иначе - сумму. Нет необходимости вычислять это вручную. Достаточно в ячейке С1 записать формулу:

=ЕСЛИ(А1>В1;А1-В1;А1+В1)

Изменив значение в ячейках А1и В1, посмотрите, что будет с содержимым ячейки С1.

Если данные уже введены в ячейку, то включить режим редактирования можно, нажав клавишу F2, либо дважды щёлкнуть мышью на подлежащей редактированию ячейке, или поместить табличный курсор в необходимую ячейку, а указатель мыши поместить на данные в строке формулы. Наконец, можно использовать клавиши подтверждения или отмены изменений, находящиеся в строке формулы.

На месте логического выражения можно использовать одну из логических функций и или или.

И(логическое выражение 1; логическое выражение 2,…)

Или(логическое выражение 1; логическое выражение 2,…)

В скобках может быть указано до пятидесяти логических выражений. Функция и принимает значение истина, если одновременно все логические выражения истинны. Функция или принимает значение истина, если хотя бы одно из логических выражений истинно.

Например: Определить, входит ли в заданный диапазон (5;10) число, содержащееся в ячейке А2. Ответ 1 ( если число принадлежит диапазону) и 0 (если не принадлежит) должен быть получен в ячейке А4.

В ячейку А4 вводится формула:

=если(и (А2>5;A2<10);1;0)

В ячейке А4 получится значение 1 если число принадлежит диапазону, и значение 0, если вне диапазона.

Счет если, подсчитывающая количество непустых ячеек, удовлетворяющих критерию внутри интервала.

Счет если(интервал; критерий).

Статистические функциивыполняют операции по вычислению параметров случайных величин или их распределений, представленных множеством чисел, например, среднего значения, стандартного отклонения и другие. Так для того, чтобы найти среднее значение (среднее арифметическое), используют функцию СРЗНАЧ. Для подсчета количества числе в списке используют функцию СЧЕТ. Подсчитать количество непустых ячеек в диапазоне можно с помощью функции СЧЕТЕСЛИ.

Для упрощения ввода в таблицу однотипных формул используется их копирование. При этом осуществляется автоматическая настройка ссылок, входящих в копируемую формулу.







Последнее изменение этой страницы: 2016-08-15; Нарушение авторского права страницы

infopedia.su Все материалы представленные на сайте исключительно с целью ознакомления читателями и не преследуют коммерческих целей или нарушение авторских прав. Обратная связь - 35.175.121.230 (0.003 с.)