Конфігурування статичних VLAN



Мы поможем в написании ваших работ!


Мы поможем в написании ваших работ!



Мы поможем в написании ваших работ!


ЗНАЕТЕ ЛИ ВЫ?

Конфігурування статичних VLAN



1. Статичні VLAN це сукупність портів на комутаторі, які вручну призначаються командою IOS при конфігуруванні інтерфейсу.

На комутаторах Cisco серії 1950 порожню VLAN створюють командою

Switch(config)#vlan #VLAN name <NAME>,

де #VLAN –ціле число –номер VLAN, <NAME> - послідовність символів – ім’я VLAN.

 

Наприклад

Switch(config)#vlan 77 name 77

Порт в VLAN додається в режимі конфігурації інтерфейсу цього порту, наприклад, команди

Switch(config)#interface Ethernet0/3

Switch(config-if)# vlan-membership static 77

додають в VLAN 77 порт 3. Якщо VLAN 77 до цього не була створена, то вона створюється з ім’ям рівним його номеру.

Після створення усіх VLAN, можна перевірити, які порти належать яким VLAN командою show vlan-membersip.

Детальну інформацію про VLAN з номером #VLAN можна отримати командою Show vlan #VLAN, наприклад

Switch#show vlan 77

Для того, щоб перевести порт у магістральний режим необхідно в режимі конфігурації інтерфейсу цього порту виконати команду

Switch(config-if)# trunk on

Вивести інтерфейс із магістрального режиму можна командою

Switch(config-if)# trunk off

Найбільш простим способом перекладу всього еthernetз’єднання точка-точка в магістральний режим є використання команди trunk on на обох інтерфейсах на кінцях з’єднання.

Для перевірки стану магістралей використовується команда

Switch#show trank (a|b).

2. Для створення порожній VLAN з номером #VLAN на комутаторах Cisco серії 2950 використовується командою

Switch#vlan database

Switch(vlan)#vlan #VLAN

SwitchVlan)#exit

Наприклад, команди

Switch#vlan database

Switch(vlan)#vlan 33

SwitchVlan)#exit

створять порожню VLAN з номером 33 і система даст VLAN ім’я VLAN0033.

Помітимо, що команди виконуються не в режимі конфігурації.

Команда switchport mode використовується для установки інтерфейсу в динамічний режим, режими доступу або режим магістралі (trunk).

Switch(config-if)#switchport mode [access | dynamic | trunk]

Хоча режим доступу є режимом за умовчанням, але в ряді випадків пристрій, приєднання до порту комутатора, може перевести його в магістральний режим. Тому рекомендуються усі немагістральні порти переводити в режим доступу командою switchport mode access.

Для статичного приміщення поточного інтерфейсу в VLAN використаються команди

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan #number,

де #number –число – номер VLAN.

Команда interface range визначає діапазон інтерфейсів для наступних конфігурацій. Наприклад, порти з першого по шостий можуть бути поміщені в VLAN 10 командами

Switch(config)#interface range fa0/1 – 6

Switch(config-if-range)#switchport access vlan 10

Після настроюванні VLAN перевірте настроювання командами show running-config, show vlan и show vlan brief.

При настроюванні VLAN пам’ятайте, що за умовчанням усі порти перебувають в VLAN 1.

Для створювання або конфігурування магістралі VLAN повинні настроїти порт як магістральний

Switch(config-if)#switchport mode trunk

За умовчанням остання команда визначає порт як магістральний для усіх VLAN у мережі. Однак існують ситуації, коли магістраль не повинна підтримувати усі VLAN. Типової є ситуація із придушенням широкомовлення. Широкомовлення надсилає на кожен порт в VLAN. Магістральний зв’язок виступає як член VLAN і повинна пропускати усі широкомовлення. Якщо на іншому кінці магістралі немає портів потрібної VLAN, то смуга пропущення й процесорний час пристроїв витрачається попусту.

Якщо VLAN не використовується на іншому кінці магістралі, немає потреби дозволяти цю VLAN на цій магістралі. За умовчанням магістральні порти приймають і передають трафік із усіх VLAN у мережі. Для скорочення магістрального трафіка використовувати команду

Switch(config-if)#switchport trunk allowed vlan vlan-list

Наприклад, команда

Switch(config-if)#switchport trunk allowed vlan 3

Switch(config-if)#switchport trunk allowed vlan 6-10

дозволяє на магістралі VLAN 3 і потім VLAN з 6 по 10. Про те, які VLAN дозволені на магістралі можна подивитися командою show running-config.

Для видалення виликого числа VLANs з магістралі простіше спочатку видалити усі VLAN, а потім вибірково дозволяти.

Найпростіший спосіб перевезти зв’язок у режим доступу це задати на інтерфейсах з її двох сторін по команді

SwitchA(config-if)#switchport mode access

Найпростіший спосіб перевести зв’язок у режим доступу це задати на інтерфейсах її двох сторін по команді

SwitchA(config-if)#switchport mode trunk

 

Практична частина

1. Зберіть топологію на комутаторах серії 1950 (рис. 7.5). Комутатори з’єднати двома Fastethernet (fa0/26 і fa0/27) з’єднаннями. Комп’ютери приєднайте до інтерфейсів відповідно до табл. 7.1. Призначте комп’ютерам адреси, відповідно до табл. 7.1. Усі комп’ютери входять в одну підмережу 172.16.0.0 255.255.0.0. Маршрути за умовчанням на комп’ютерах не встановлювати. Пропінгуйте мережу.

Організуйте в мережі два VLAN. Комп’ютери 20_1 і 20_2 помістити в VLAN з номером 20, а комп’ютери 30_1 і 30_2 помістить в VLAN з номером 30.

1912-1(conf)#interface Ethernet0/2

1912-1(conf-if)#vlan-membership static 20

1912-1(conf-if)#interface Ethernet0/3

1912-1(conf-if)#vlan-membership static 30

1912-2(conf)#interface Ethernet0/2

1912-2(conf-if)#vlan-membership static 20

1912-2(conf-if)#interface Ethernet0/3

1912-2(conf-if)#vlan-membership static 30

Рис. 7.5 VLAN на комутаторах серії 1950.

 

Комп’ютер 1912-1 1912-2 Адреса
20_1 E0/2   172.16.20.1/16
30_1 E0/3   172.16.20.2/16
20_2   E0/2 172.16.30.1/16
30_2   E0/3 172.16.30.2/16
  Fa/26 Fa/26  
  Fa/27 Fa/27  

Таблиця 7.1 Адреси для VLAN на рис. 7.5.

 

 

На обох комутаторах перевірте результати створення VLAN, наприклад

 

 

 

 

і

 

 

Якщо немає обміну інформації про VLAN між комутаторами, то комп’ютери будуть пінговать тільки самих себе.

Організуйте магістралі на комутаторах. Для цього використаємо магістралі відразу по двох Fastethernet портам

1912-1(conf)#interface FastEthernet0/26

1912-1(conf-if)#trunk On

1912-1(conf-if)#FastEthernet0/27

1912-1(conf-if)#trunk On

1912-2(conf)#interface FastEthernet0/26

1912-2(conf-if)#trunk On

1912-2(conf-if)#FastEthernet0/27

1912-2(conf-if)#trunk On

Перевірте стан магістралей командами show trunk a і show trank b. Тепер комп’ютери в переделах однієї VLAN повинні пінгуватися, а комп’ютери, перебувають у різних VLAN не повинні пінгуватися (см. Табл. 7.2).

 

Таблиця 7.2 Зв’язок між VLAN.

Ping из/в 20_1 30_1 20_2 30_2
20_1 Да Ні Да Ні
30_1 Ні Да Ні Да
20_2 Да Ні Да Ні
30_2 Ні Да Ні Да

 

Збережіть конфігурацію. Визначитесь з тим який .rtr файл за який пристрій відповідає.

2. Завантажте дизайнер і змінить топологію. У цій топології маршрутизатор моделі 2612 з’єднано двома зв’язками з інтерфейсами e0/12 комутаторів (рис. 7. 6). Завантажте топологію в симулятор. Завантажте по черзі в кожен пристрій збережену конфігурацію. Знову перевірте, що комп’ютери в переділах однієї VLAN пінгуються, а комп’ютери, що перебувають у різних VLAN не пінгуються.

 

Рис. 7.6 VLAN з маршрутизатором.

 

Поставте завдання об’єднання віртуальних мереж за допомогою маршрутизатора. Для цього слід розбити мережу 172.16.0.0/16 на дві підмережі 172.16.20.0/24 і 172.16.30.1/24. Для цього просто поміняйте маски в комп’ютерів на 255.255. 255.0.

Тепер комп’ютери пінгуються в переділах однієї VLAN і в переділах однієї IP підмережі, а це значить тільки самі на себе.

Введіть на комутаторах інтерфейси, приєднані до маршрутизатору у віртуальні мережі

1912-1(conf)#interface Ethernet0/12

1912-1(conf-if)#vlan-membership static 20

1912-2(conf)#interface Ethernet0/12

1912-2(conf-if)#vlan-membership static 30

Настройте IP-адреси на маршрутизаторі

Router(conf)#interface Ethernet0

Router(conf-if)#ip address 172.16.20.254 255.255.255.0

Router(conf-if)#no shutdown

Router(conf-if)#interface Ethernet1

Router(conf-if)#ip address 172.16.30.254 255.255.255.0

Router(conf-if)#no shutdown

Тепер маршрутизатор маршрутизує дві мережі 172.16.20.0/24 і 172.16.30.1/24. Додайте на комп’ютерах маршрутизацію за умовчанням на інтерфейси маршрутизатора

20_1#ipconfig /dg 172.16.20.254

20_2#ipconfig /dg 172.16.20.254

30_1#ipconfig /dg 172.16.30.254

30_2#ipconfig /dg 172.16.30.254

Тепер із усіх пристроїв мережі можна пінговать усі IP-адреси.

3. Покажіть, як з використанням транзитних ліній, можна заощадити порти.

Змінить топологію, перекинувши магістраль fa0/26 від комутаторів до інтерфейсу fa0/0 маршрутизатора (рис. 7.7). Завантажте топологію в симулятор. Завантажте почергово збережені конфігурації в кожен пристрій, крім маршрутизатора,. Помітимо, що в конфігурації комутатора 1912-2 установка магістралі на fa0/26 не потрібна, хоча вона і не заважає.

 

Рис. 7.7 VLAN з маршрутизатором і підінтерфейсами.

 

На маршрутизаторі розіб’єм інтерфейс fa0/0 на два підінтерфейси fa0/0.20 і fa0/0.30. Визначте на них інкапсуляцію isl і помістити їх у віртуальні мережі 20 і 30, відповідно.

Router(conf)#interface FastEthernet0/0.20

Router(conf-subif)#encapsulation isl 20

Router(conf-subif)#ip address 172.16.20.254 255.255.255.0

Router(conf-subif)#interface FastEthernet0/0.30

Router(conf-subif)#encapsulation isl 30

Router(conf-subif)#ip address 172.16.30.254 255.255.255.0

Подивіться таблицю маршрутів

Router#show ip route

Перевірте, що з кожного пристрою можна пінгувати усі адреси в мережі.

Виконати на Router команду розширеного пінга від адреси 172.16.20.1 комп’ютера 20_1 з VLAN 20, підключеного до комутатора 1912_1 до адреси 172.16.30.2 комп’ютери 30_2 з VLAN 30, підключеного до комутатора 1912_2

 

Контрольні питання

1. Чому переважно будують локальні мережі за допомогою комутаторів, а не концентраторів?

2. Які існують методи для відправлення фрейму через комутатор?

3. Як комутатор з’ясовує МАС адреси підключених пристроїв?

4. Де і як у комутаторі зберігаються адреси підключених пристроїв?

5. Що таке віртуальне з’єднання і як довго воно існує?

6. Як за допомогою комутаторів можна створити велику локальну мережу?

7. Як прийнято будувати великі локальні мережі?

8. Що є головною перешкодою для створення великих локальних мереж за допомогою одних тільки комутаторів?

9. Що таке домен широкомовлення?

10. Як зменшити домен широкомовлення?

11. Що таке VLAN?

12. Які проблеми локальних мереж вирішує VLAN?

13. Як у локальній мережі організувати обмін інформацією про VLAN?

14. У яких режимах працюють порти комутатора?

15. Якій VLAN належить магістральний порт?

16. Як поширити одну VLAN на кілька комутаторів?

17. Чи можна організувати декілька VLAN на декількох комутаторах без використання магістралей?

18. Навіщо потрібні протоколи ISL і IEEE 802.1Q?

19. Навіщо потрібні магістралі у локальній мережі?

20. Які завдання вирішує VTP?

21. Які завдання вирішує STP?

22. Якими командами можна організувати VLAN?

23. Якою командою перевести порт у режим доступу й у режим магістралі?

24. Якою командою можна отримати інформацію про VLAN?

25. У локальній мережі є одинадцять VLAN. Скільки маршрутизаторів необхідно для об’єднання усіх 11 VLAN у єдине ціле?

 



Последнее изменение этой страницы: 2016-04-18; Нарушение авторского права страницы; Мы поможем в написании вашей работы!

infopedia.su Все материалы представленные на сайте исключительно с целью ознакомления читателями и не преследуют коммерческих целей или нарушение авторских прав. Обратная связь - 18.232.50.137 (0.02 с.)