Конфігурування динамічної маршрутизації



Мы поможем в написании ваших работ!


Мы поможем в написании ваших работ!



Мы поможем в написании ваших работ!


ЗНАЕТЕ ЛИ ВЫ?

Конфігурування динамічної маршрутизації



Для конфігурування динамічної маршрутизації використаються дві основні команди: router і network. Команда router запускає процес маршрутизації і має форму:

Router(config)# router protocol [keyword]

де Protocol - кожен з протоколів маршрутизації: RIP, IGRP, OSPF і т.і., keyword –додаткові параметри.

Потім необхідні команди network:

Router ( config-router)# network network-number [keyword]

де network-number - ідентифікує безпосередньо підключену мережу, що додається в процес маршрутизації, keyword – додаткові параметри. network-number дозволяє процесу маршрутизації визначити інтерфейси, які будуть брати участь у відсиланні й прийомі пакетів актуалізації маршрутної інформації.

Для перегляду інформації про протоколи маршрутизації використовується команда show ip protocol, яка виводить значення таймерів процесів маршрутизації й мережну інформацію, що має відношення до маршрутизації. Ця інформація може використовувати ся для ідентифікації маршрутизатора, підозрюваного в поставці поганої маршрутної інформації

Вміст таблиці IP маршрутизації виводиться командою show ip route. Вона містить записи про усі відомі маршрутизатору мережі й підмережі і вказує на спосіб отримання цієї інформації

 

Протокол RIP

Ключові характеристики протоколу RIP:

· маршрутизація на підставі вектора відстані;

· метрика при виборі шляху у вигляді кількості переходів (хопів);

· максимально припустиме кількості хопів - 15;

· за умовчанням пакети актуалізації маршрутної інформації надсилаються у режимі широкомовлення кожні 30 секунд.

Вибір протоколу RIP як протоколу маршрутизації здійснюється командою:

Router(config)# router rip

Команда network назначає IP-адресу мережі з якої маршрутизатор має безпосереднє з’єднання.

Router( config-router)# network network-number

Процес маршрутизації зв’язує інтерфейси з відповідними адресами й начинає обробку пакетів у заданих мережах.

На рис. 2.2 показані приклади: командиnetwork 1.0.0.0 і network 2.0.0.0 задають безпосередньо підключені до маршрутизатора Cisco А мережі.

Рис. 2.2 RIP маршрутизація.

 

Команда debug ip rip виводить зміст пакетів актуалізації маршрутної інформації протоколу RIP у тому вигляді, в якому ці дані надсилаються і приймаються.

 

Протокол IGRP

IGRP представляє собою дистанційно-векторнийпротокол маршрутизації розроблений компанією Cisco. Цій протокол надсилає пакети актуалізації маршрутної інформації з 90-секундним інтервалом, у яких утримуються відомості про мережі для конкретної автономної системи. Цей протокол характеризує універсальність, що дозволяє автоматично справлятися зі складними токологіями й гнучкістю у роботі із сегментами, що мають різні характеристики по смузі пропущення й величини затримки. Використана їм метрика не має властивих протоколів RIP обмежень по кількості переходів. Вона включає наступні складові: Ширина смуги пропущення; Величина затримки; Рівень завантаження; Надійність каналу; Розмір максимального блоку передачі в каналі.

Вибір протоколу IGRP, як протокол маршрутизації здійснюється за допомогою команди:

Router (config)# router igrp autonomous-system,

де параметр Autonomous-system називають номером автономної системи й він ідентифікує обчислювальний процес IGRP- маршрутизації. Процеси в маршрутизаторах мережі з однаковим номером autonomous-system будуть колективно використовувати маршрутну інформацію.

Команда network задає безпосередньо приєднані мережі, які підлягають включенню в даний процес маршрутизації:

Router( config-router)#network network-number

На рис. 2.3 показані приклади: на маршрутизаторі Cisco A запущено маршрутизуючий процес, що організує IGRP маршрутизацію в автономній системі з номером 109. У маршрутизації будуть брати участь мережі 1.0.0.0 і 2.0.0.0.

 

Рис. 2.3 IGRP маршрутизація.

 

Команди debug ip igrp transactions іdebug ip igrp events виводять зміст пакетів актуалізації маршрутної інформації протоколу IGRP у тому вигляді, в якому ці данні надсилаються і приймаються.

 

Протокол OSPF

OSPF це динамічний, ієрархічний протокол стану зв’язку, який використовується для маршрутизації усередині автономних систем. Він базується на відкритих стандартах і був спроектовано як заміна протоколу RIP. Він є розвитком ранніх версій протоколу маршрутизації IS-IS. OSPF - стійкій протокол, підтримує маршрутизацію з найменшою вагою і балансування завантаження. Найкоротший шлях у мережі обчислюється по алгоритму Дейкстри. Cisco підтримує свою версію стандарту OSPF.

Як тільки маршрутизатор налаштовано на роботу з OSPF, він починає процес вивчення оточення, проходячи кілька фаз ініціалізації. На початку маршрутизатор використає фазу Hello для визначення своїх сусідів і створення відносин для обміну відновлення маршрутної інформації з ним. Потім маршрутизатор починає фазу ExStart початкового обміну між базами маршрутів. Наступної є фаза обміну, у якій призначений маршрутизатор відсилає маршрутну інформацію й отримує підтвердження від нового маршрутизатора. Протягом стадії завантаження, новий маршрутизатор компілює таблицю маршрутів. По закінченню обчислень маршрутизатор переходить у повний стан, у якому він є активним членом мережі.

Для запуску OSPF маршрутизації служить команда

Router(config)#router ospf N,

де N-номер обчислювального процесу OSPF. На відміну від IGRP він може бути різним для різних маршрутизаторів автономної системи. OSPF область Area організується командою

Router(config-router)# network network-number area Area

і визначає автономну систему.

У OSPF network-number має особливий формат. Для маршрутизації, що підключає в процес, в мережі використовується інверсна маска. Так, щоб мережу 212.34.0.0 255.255.0.0 помістити в область 7 OSPF маршрутизації слід дати команду

Router(config-router)# network 212.34.0.0 0.0.255.255 area 7

Команда show ip ospf interface для кожного інтерфейсу виводить всю OSPF інформацію: IP-адреса, область, номер процесу, ідентифікатор маршрутизатора, вартість, пріоритет, тип мережі, інтервали таймера.

Команда show ip ospf neighbor показує важливу інформацію, що стосується стану сусідів.

 

Практична частина

1. Завантажте в симулятор топологію й конфігурацію, використану практичної частини лабораторної роботи №1.

2. Якщо зроблено все правильно, зможете пропінгувати із будь-якого маршрутизатора адреса безпосередньо з’єднані інтерфейси інших маршрутизаторів. На кожному пристрої, використовуючи команди CDP show cdp neighbors detail, отримати IP-адреса сусідніх пристроїв і пропінгуйте їх.

У лабораторній роботі №1 за допомогою статичної маршрутизації вирішили проблему маршрутизації мережі на рис. 2.4. У цій роботі для рішення проблеми використайте різні форми динамічної маршрутизації.

Рис. 2.4 Учбова мережа.

.

3. Подивиться таблицю маршрутів

Router2#sh ip route

Немає маршруту в мережі 172.16.10.0/24.

Тому в цю мережу з Router2 не йдуть пінги.

Router4#sh ip route

Немає маршруту в мережі 10.1.1.0/24.

Тому в цю мережу з Router4 не йдуть пінги.

 

RIP

1. Включить RIP на усіх маршрутизаторах

Router1(config)#router rip

Router1(config-router)#network 172.16.10.0

Router1(config-router)#network 10.1.1.0

Router2(config)#router rip

Router2 (config-router)#network 10.1.1.0

Router4(config)#router rip

Router4 (config-router)#network 172.16.10.0

2. Для кожного роутера командою show running-config подивиться як маршрутизатори зрозуміли наші команди. Мережа 10.1.1.0/24 сприйнята як мережа 10.0.0.0/8, а мережа 172.16.10.0/24 сприйнята як мережа 172.16.10.0/16. Це пов’язане з класами IP-адрес.

3. Командою show ip protocols подивиться з яких параметрів працює протокол RIP. Наприклад, для Router1 маємо

Перекладіть повідомлення.

4. Подивиться таблицю маршрутів

Router2#sh ip route

Є маршрут для мережі 172.16.10.0/24 через інтерфейс Ethernet на адресу 10.1.1.1.

Пінги для цієї мережі з Router2 підуть. Перевірте

Router2#ping 172.16.10.1

Router2# ping 172.16.10.2

5. Перейдіть на інший маршрутизатор

Router4#sh ip route

Є маршрут для мережі 10.1.1.0/24 через інтерфейс Serial на адресу 172.16.10.1.

Пінги для мережі з Router4 підуть. Перевірте

Router4#ping 10.1.1.1

Router4# ping 10.1.1.2.

  1. Командою debug ip rip подивиться як маршрутизатори обмінюються маршрутною інформацією. Наприклад, для Router1 маємо повторювані кожні 30 секунд повідомлення

Router1#debug ip rip

Видалить трасировку

Router1#no debug ip rip

Збережіть конфігурацію.

IGRP

Зупиніть на усіх маршрутизаторах RIP командою

Router(config)#no router rip.

1. Включить IGRPна усіх маршрутизаторах для автономної системи з номером 100

Router1(config)#router igrp 100

Router1(config-router)#network 172.16.10.0

Router1(config-router)#network 10.1.1.0

Router2(config)#router igrp 100

Router2 (config-router)#network 10.1.1.0

Router4(config)#router igrp 100

Router4 (config-router)#network 172.16.10.0

2. Для кожного маршрутизатора команда show running-config подивиться як маршрутизатори зрозуміли ці команди. Мережа 10.1.1.0/24 сприйнята як мережа 10.0.0.0/8, а мережа 172.16.10.0/24 сприйнята як мережа 172.16.10.0/16. Це пов’язано з класами IP-адрес.

3. Командою show ip protocols подивиться з якими параметрами працює протокол IGRP. Наприклад, для Router1 маємо

Переведіть повідомлення.

4. Подивиться таблицю маршрутів

Router2#sh ip route

Є маршрут для мережі 172.16.10.0/24 через інтерфейс Ethernet на адресу 10.1.1.1.

Пінги для мережі з Router2 підуть. Перевірте

Router2#ping 172.16.10.1

Router2# ping 172.16.10.2

5. Перейдіть на інший маршрутизатор

Router4#sh ip route

Є маршрут для мережі 10.1.1.0/24 через інтерфейс Serial на адресу 172.16.10.1.

Пінги для мережі з Router4 підуть. Перевірте

Router4#ping 10.1.1.1

Router4# ping 10.1.1.2.

  1. Командами debug ip igrp transactionsіdebug ip igrp events подивиться як маршрутизатори обмінюються маршрутною інформацією.

Збережіть конфігурацію.

 

OSPF

Зупинить на усіх маршрутизаторах IGRP команду

Router(config)#no router igrp 100

1. Включить OSPFна усіх маршрутизаторах. Дати процесу OSPF номер 100. Утворити OSPF область 0

 

Router1(config)#router ospf 100

Router1(config-router)#network 172.16.10.0 0.0.255 area 0

Router1(config-router)#network 10.1.1.0 0.0.255 area 0

Router2(config)#router ospf 100

Router2(config-router)#network 10.1.1.0 0.0.255 area 0

 

Router4(config)#router ospf 100

Router4(config-router)#network 10.1.1.0 0.0.255 area 0

2.Команда show running-config показує, що маршрутизатори зрозуміли команди в тому вигляді, як їх задавали.

3. Команда show ip protocols подивиться з якими параметрами працює протокол OSPF. Наприклад, для Router1 маємо

Переведіть повідомлення.

4. Подивиться таблицю маршрутів

Router2#sh ip route

Є маршрут для мережі 172.16.10.0/24 через інтерфейс Ethernet на адресу 10.1.1.1.

Пінги для мережі з Router2 підуть. Перевірте

Router2#ping 172.16.10.1

Router2# ping 172.16.10.2

5. Перейдіть на інший маршрутизатор

Router4#sh ip route

Є маршрут для мережі 10.1.1.0/24 через інтерфейс Serial на адресу 172.16.10.1.

Пінги для мережі з Router4 підуть. Перевірте

Router4#ping 10.1.1.1

Router4#ping 10.1.1.2.

  1. Командиshow ip ospf interface, show ip ospf databaseіdebug ip igrp neighbor покажуть всю інформацію про параметри протоколу OSPF.

Збережіть конфігурацію.

 

Контрольні питання

1. Що таке автономна система.

2. Що таке метрика?

3. Яки існують два класи протоколів динамічної маршрутизації.

4. Поясніть роботу дистанційно-векторних протоколів.

5. Поясніть роботу протоколів стану зв’язку.

6. Як дізнатися, які протоколи маршрутизації запущені на маршрутизаторі?

7. У чому переваги й недоліки дистанційно-векторних протоколів і протоколів стану зв’язку?

8. Що таке збіжність протоколів маршрутизації?

9. Які параметри впливають на швидкість збіжності?

10. Як на маршрутизаторі запустити й настроїти протокол маршрутизації RIP?

11. Як на маршрутизаторі запустити й настроїти протокол маршрутизації IGRP?

12. Як на маршрутизаторі запустити й настроїти протокол маршрутизації OSPF?

13. Як подивитись зміст пакетів актуалізації маршрутної інформації протоколу RIP?

14. Як подивитися зміст пакетів актуалізації маршрутної інформації протоколу IGRP?

15. Уточните, що в IGRP зрозуміти під автономною системою?

16. У чому розходження у форматі команди router для IGRP і OSPF?

17. У чому розходження у форматі команд network для RIP, IGRP і OSPF?



Последнее изменение этой страницы: 2016-04-18; Нарушение авторского права страницы; Мы поможем в написании вашей работы!

infopedia.su Все материалы представленные на сайте исключительно с целью ознакомления читателями и не преследуют коммерческих целей или нарушение авторских прав. Обратная связь - 54.236.58.220 (0.018 с.)