Конфігурування підінтерфейсів для Frame Relay



Мы поможем в написании ваших работ!


Мы поможем в написании ваших работ!



Мы поможем в написании ваших работ!


ЗНАЕТЕ ЛИ ВЫ?

Конфігурування підінтерфейсів для Frame Relay



Підінтерфейси є логічні підрозділи фізичного інтерфейсу. За допомогою конфігурації підінтерфейсів кожен PVC може бути настроєно як з’єднання точка-точка. Це дозволяє кожному підінтерфейсу діяти як орендована лінія. Це тому, що кожен підінтерфейс точка-точка розглядається як окремий фізичний інтерфейс.

У випадку точка-точка використовується єдиний підінтерфейс для встановлення PVC з’єднання з іншим фізичним інтерфейсом або підінтерфейсом на вилученому комп’ютері. У цьому випадку кожна пара підінтерфейсів може перебувати у своєї власної підмережі й кожен підінтерфейс має єдиний DLCI.

Для конфігурування підінтерфейсів на фізичному інтерфейсі призначається інкапсуляція Frame Relay (cisco або ietf). Якщо фізичному інтерфейсі вже має IP-адресу, її слід видалити, тому що кожен підінтерфейс має власну IP-адресу. Якщо фізичний інтерфейс має адрес, то фрейми не будуть отримані локальними підінтерфейсами:

RTA(config)#interfaces0/0

RTA(config-if)#encapsulation frame-relay ietf

Далі, визначити підінтерфейси, використовуючи наступні команди.

Router(config-if)#interface serial number subinterface-number {multipoint | point-to-point}

Наступна команда створює підінтерфейс 2 типи точка-точка на Serial 0/0:

RTA(config)#interface serial s0/0.2 point-to-point

Наступна команда створює підінтерфейс 5 типу multipoint на Serial 2/0:

RTA(config)#interface serial s2/0.5 multipoint

Помітимо, що після введення цих команд операційна система IOS змінює рядок запрошення на config-subif, що означає режим конфігурації підінтерфейсу.

Номера підінтерфейсів можуть бути призначені у режимі конфігурації підінтерфейсу або в глобальному конфігураційному режимі в діапазоні від 1 до 4294967295. При конфігурації підінтерфейсу точка-точка, звичайною практикою є нумерувати підінтерфейс відповідно до значення DLCI даного PVC.

Після створення підінтерфейсу слід задати IP-адрес

RTA(config-subif)#ip address 2.1.1.1 255.255.255.0

Далі або конфігурується статичне відображення Frame Relay або використовується команда frame-relay interface-dlci для асоціації підінтерфейсу з DLCI. Ця команда потребує для усіх підінтерфейсів точка-точка. Вона також потрібна для підінтерфейсів multipoint с дозволеним режимом інверсного ARP. Вона не потребується для підінтерфейсів multipoint, які конфігуруються за допомогою статичних відображень маршрутів.

Рисунок 21.8 - Frame Relay LMI

Якийсь комутатор Frame Relay на рис. 21.8 використає LMI для інформування RTA, що доступно три активних PVC з DLCI номерами 18, 19, and 20.

Коли RTA з’ясовує про DLCI 18, 19 і 20 на інтерфейсі S0/0, RTA не знає який DLCI використовувати з яким підінтерфейсом. Це тому, що LMI не надає способу повідомлення RTA про те, що DLCI 20 повинен бути використаний інтерфейсом S0/0.2, а не S0/0.1. Адже, кожен підінтерфейс повинен бути вручну асоційовано із прийнятним номером DLCI.

Режим multipointпідтримується симулятором не повністю й розглядатися не буде.

Практична частина

Босон дизайнер завжди створює повнозв’язну топологію Frame Relay. Для створення мережної топології з використанням Frame Relay, спочатку слід визначить, які маршрутизатори й через які свої послідовні інтерфейси будуть приєднані до Frame Relay. Далі натисніть правою кнопкою миші на одному з таких маршрутизаторів, який буде приєднуватися до Frame Relay, і виберіть пункти контекстного меню Add connection потім потрібний інтерфейс serial. У модальному вікні, що з’явилося, виділить радіокнопку Point-to-Multy-Point Serial Connection (Frame Relay). Натисніть кнопку Next. З’явиться нове модальне вікно. Виберіть у першому списку перший маршрутизатор, який хотіли б приєднати до Frame Relay, у другому списку виберіть його інтерфейс, яким він буде з’єднаний до Frame Relay і натисніть кнопку Add. Виберіть у першому списку другий маршрутизатор, який хотіли б приєднати до Frame Relay, у другому списку виберіть його інтерфейс, яким він буде з’єднаний до Frame Relay і натисніть кнопку Add. Так повторити для усіх маршрутизаторів. Натисніть кнопку Connect. Дизайнер створить повнозв’язну топологію, визначивши PVC і DLCI. З’явиться вікно із призначеним DLCI. Можно їх відредагувати. Рекомендується з ними погодитися, нажавши OK. У наслідку можна змінити значення DLCI, нажавши правою кнопкою миші на хмарі Frame Relay.

Симулятор не повною мірою підтримує Frame Relay.

1. Створити топологію на 805 маршрутизаторах (рис. 21.9)

Рисунок 21.9 - Учбова Frame Relay мережа

 

Конфігуруйте Frame Relay згідно з рис. 21.10.

Рисунок 21.10 - Конфігурація мережі на рис. 21.9

 

1.1 Динамічне призначення адрес

Router1(config)# interface serial0

Router1(config-if)# encapsulation frame-relay

Router1(config-if)# ip address 215.10.1.1 255.255.255.0

Router1(config-if)# no frame-relay inverse-arp

Router1(config-if)# no shut

Router2(config)# interface serial0

Router2(config-if)# encapsulation frame-relay

Router2(config-if)# ip address 215.10.1.2 255.255.255.0

Router2(config-if)# no shut

Введіть команду show interfaces serial0 на обох маршрутизаторах. Вона покаже з’єднані до Frame Relay. Повинні побачити фрази ‘up and line protocol is up’ и ‘DTE LMI up’.

Введіть команду show frame-relay map на обох маршрутизаторах. На Router1 вона нічого не покаже, тому що відключено inverse-arp. На Router2 вона покаже відображення локального DLCI на вилучений ІP адрес 201-215.10.1.1.

Команда show frame-relay pvc повинна показати статус PVC ‘ACTIVE’ на Router2 і статус PVC ‘INACTIVE’ на Router1.

Включить inverse-arp

Router1(config-if)#frame-relay inverse-arp

Тепер на Router1 команду show frame-relay map покаже відображення локального DLCI на вилучений IP-адрес 215.10.1.2. Команда show frame-relay pvc повинна показати статус PVC ‘ACTIVE’ на Router1. Пропінгувати обидва маршрутизатори.

1.2 Статичне призначення адрес симулятор версії 5.3 не підтримує. Симулятор версії 6.0 Final beta підтримує.

Завантажить колишню топологію з рис. 6.9 і 6.10.

и створити нову конфігурацію

Router1(config)#interface serial0

Router1(config-if)#encapsulation frame-relay

Router1(config-if)#ip address 215.10.1.1 255.255.255.0

Router1(config-if)#frame-relay map ip 215.10.1.2 102 broadcast

Router1(config-if)#no shut

Router2(config)#interface serial0

Router2(config-if)#encapsulation frame-relay

Router2(config-if)#ip address 215.10.1.2 255.255.255.0

Router2(config-if)#frame-relay map ip 215.10.1.1 201 broadcast

Router2(config-if)#no shut

Введіть на обох маршрутизаторах команди show interfaces serial0, show frame-relay map, show frame-relay pvcіshow frame-relay lmi.Пропінгувати обидва маршрутизатори.

1.3 Використання підінтерфейсів

Завантажте колишню топологію з рис. 6.9 і 6.10 і створити нову конфігурацію

Router1(config)#interface seria0

Router1(config-if)#encapsulation frame-relay

Router1(config-if)#no shut

Router1(config-if)#interface serial0.102 point-to-point

Router1(config-subif)#ip address 215.10.1.1 255.255.255.0

Router1(config-subif)#frame-relay interface-dlci 102

Router2(config)#interface serial0

Router2(config-if)#no shut

Router2(config-if)#encapsulation frame-relay

Router2(config-if)#interface serial0.201 point-to-point

Router2(config-subif)#ip address 215.10.1.2 255.255.255.0

Router2(config-subif)#frame-relay interface-dlci 201

Введіть на обох маршрутизаторах команду show ip interface brief. Повинні побачити призначені адреси і активні стани інтерфейсів (status = up). Команда show frame-relay map не показує адреси для підінтерфейсів, а виводить співвідношення підінтерфейс – DLCI. Цю інформацію виводить і команда show frame-relay pvc. Пропінгувати обидва маршрутизатори.

2. Створити топологію глобальної мережі фірми з трьох філіалів як на рис. 6.11. Не втрачаючи спільності як моделі локальних мереж філіалів використовувати по одному комп’ютеру. Призначити DLCI відповідно рис. 21.12.

Рисунок 21.10 - Учбова Frame Relay мережа

 

Конфігуруйте три маршрутизатори для Frame Relay для зв’язку трьох філіалів фірми по повнозв’язної топології. Як протокол маршрутизації використайте OSPF.

Динамічне настроювання

На маршрутизаторі SanJose1

Router(config)#hostname SanJose

SanJose(config)#interface Serial0

SanJose(config-if)#ip address 192.168.192.1 255.255.255.0

SanJose(config-if)#encapsulation frame-relay

SanJose (config-if)#no shut

SanJose(config-if)#interface Ethernet0

SanJose(config-if)#ip address 192.168.0.1 255.255.255.0

SanJose (config-if)#no shut

SanJose(config-if)#exit

SanJose(config)#Router ospf 100

SanJose(config-Router)#network 192.168.0.0 0.0.255.255 area 1

На маршрутизаторі London

Router(config)#hostname London

London(config)#interface Serial0

Рисунок 21.12 - Конфігурація мережі на рис. 21.11

 

London(config-if)#ip address 192.168.192.2 255.255.255.0

London(config-if)#encapsulation frame-relay

London (config-if)# no shut

London(config-if)#interface Ethernet0

London(config-if)#ip address 192.168.200.1 255.255.255.0

London (config-if)# no shut

London(config-if)# exit

London(config)#Router ospf 100

London(config-Router)#network 192.168.0.0 0.0.255.255 area 1

 

На маршрутизаторі Singapore

Router(config)#hostname Singapore

Singapore(config)#interface Serial0

Singapore(config-if)#ip address 192.168.192.4 255.255.255.0

Singapore(config-if)#encapsulation frame-relay

Singapore (config-if)# no shut

Singapore(config-if)#interface Ethernet0

Singapore(config-if)#ip address 192.168.232.1 255.255.255.0

Singapore (config-if)# no shut

Singapore (config-if)# exit

Singapore(config)#Router ospf 100

Singapore(config-Router)#network 192.168.0.0 0.0.255.255 area 1

Введіть на усіх маршрутизаторах команди show ip interface briefи show interfaces serial0. Повинні побачити стани інтерфейсів. Введіть на обох маршрутизаторах команду show frame-relay pvc. Подивитесь стани каналів frame relay (pvc status). Наприклад

Singapore#show frame-relay pvc

Подивиться активні канали на SanJose (DLCI=301) і London (DLCI=302).

У реальних мережах Frame Relay стани каналів можуть бути ACTIVE, INACTIVE і DELETED. ACTIVE це працездатний ланцюг від кінця в кінець (DTE до DTE). Стан INACTIVE показує успішне приєднання до комутатора Frame Relay (DTE к DCE) при відсутності маршрутизатора (DTE ) на іншому кінці PVC. Цей стан трапляється, коли маршрутизатор на іншому кінці PVC або не бере участь в Frame Relay для цієї мережі або не налаштовано. Стан DELETED трапляється коли маршрутизатор (DTE) і комутатор Frame Relay не домовились про параметри Frame Relay на цьому PVC.

 

Симулятор версії 5.3 не повною мірою підтримує стану.

Команда show frame-relay map покаже динамічно назначене відображення зовнішній IP-адреси-локальний dlci для каналу на вилучений маршрутизатор з цим зовнішній IP-адресою. Наприклад

Singapore#show frame-relay map

Подивиться адреса інших маршрутизаторів. Як маршрутизатор Singapore їх з’ясовує? Коли маршрутизатор Singapore отримує по протоколі LMI список DLCI, він надсилає інверсні ARP запити до кожного свого виявленого PVC каналу. Маршрутизатор на іншому кінці PVC повертає свій IP-адрес.

З таблиці подивіться, що широкомовлення broadcast дозволені, що дозволяє протоколам маршрутизації обмінюватися маршрутною інформацією. Використовуючи команду show ip route, переконайтеся, що з Лондона є маршрут на Сінгапур

London#show ip route

Лондон має маршрут на мережу 192.168.232.0/24 Сінгапура на адрес 192.168.192.4 через Serial0.

Бачимо, що тільки зоднимфізичним зв’язком до Frame Relay кожен маршрутизатор має по два логічних зв’язка.

Сконфігуруйте локальні мережі філіалів згідно табл.. 21.1

Таблиця 21.1 - Конфігурація локальних мереж філіалів на рис. 21.11.

РС IP Шлюз
PCSJ 192.168.0.2 192.168.0.1
PCL 192.168.200.2 192.168.200.1
PCS 192.168.232.2 192.168.232.1

 

Перевірить повну конфігурацію за допомогою розширеної команди ping. Наприклад можете з маршрутизатора в SanJose перевірити чи є зв’язок від філіального комп’ютера PCL у Лондоні до філіального комп’ютера PCS у Сінгапурі.

Статичне налаштування

Використовувати симулятор версії 6.0 Final beta.

Мережні інженери можуть бути не задоволені неявною динамічною конфігурацією. Зручності динамічного відображення DLCI - IP мінімальні через статичний характер більшості глобальних зв’язків. Коли з’єднання встановлено, воно не змінюється роками.

Об’єднайте філіали в глобальну мережу статично. Для цього слід створити нову конфігурацію заново. Завантажити в симулятор колишню створену топологію й настройте маршрутизатори

SanJose

Router(config)#hostname SanJose

SanJose(config)#interface Serial0

SanJose(config-if)#ip address 192.168.192.1 255.255.255.0

SanJose(config-if)#encapsulation frame-relay

SanJose(config-if)#no frame-relay inverse-arp

SanJose(config-if)#frame-relay map ip 192.168.192.2 102 broadcast

SanJose(config-if)#frame-relay map ip 192.168.192.4 103 broadcast

SanJose (config-if)#no shut

SanJose(config-if)#interface Ethernet0

SanJose(config-if)#ip address 192.168.0.1 255.255.255.0

SanJose (config-if)#no shut

SanJose(config-if)#exit

SanJose(config)#Router ospf 100

SanJose(config-Router)#network 192.168.0.0 0.0.255.255 area 1

London

Router(config)#hostname London

London(config-if)#interface Serial0

London(config-if)#ip address 192.168.192.2 255.255.255.0

London(config-if)#no frame-relay inverse-arp

London(config-if)#encapsulation frame-relay

London(config-if)#frame-relay map ip 192.168.192.1 201 broadcast

London(config-if)#frame-relay map ip 192.168.192.4 203 broadcast

London (config-if)#no shut

London(config-if)#interface Ethernet0

London(config-if)#ip address 192.168.200.1 255.255.255.0

London (config-if)#no shut

London(config-if)#exit

London(config)#Router ospf 100

London(config-Router)#network 192.168.0.0 0.0.255.255 area 1

Singapore

Router(config)#hostname Singapore

Singapore (config)#interface Serial0

Singapore (config-if)#ip address 192.168.192.4 255.255.255.0

Singapore (config-if)# encapsulation frame-relay

Singapore (config-if)#no frame-relay inverse-arp

Singapore (config-if)#frame-relay map ip 192.168.192.1 301 broadcast

Singapore (config-if)#frame-relay map ip 192.168.192.2 302 broadcast

Singapore (config-if)#no shut

Singapore (config-if)#interface Ethernet0

Singapore (config-if)#ip address 192.168.232.1 255.255.255.0

Singapore (config-if)#no shut

Singapore (config-if)#exit

Singapore (config)#Router ospf 100

Singapore (config-Router)#network 192.168.0.0 0.0.255.255 area 1

 

Використали команду no frame-relay inverse-arp,тому, що без неї симулятор відображає адреси як статично так і динамічно.

Команда frame-relay map асоціює IP-адресу наступного хопа з локальним DLCI. Ключове слово broadcast дозволяє проходження широкомовного трафіка, наприклад для інформації про маршрути для протоколів маршрутизації.

Введіть на усіх маршрутизаторах команди show ip interface brief і show interfaces serial0. Побачите стан інтерфейсів. Введіть на обох маршрутизатора команди show frame-relay pvcі show frame-relay lmi. Побачите стан frame relay. Команда show frame-relay map покаже статично призначене відображення зовнішня IP-адреса-локальна dlci для канади pvc на вилучений маршрутизатор із цим зовнішнім IP-адресом. Повинні побачити слово static. Наприклад SanJose)# show frame-relay map

Використовуючи команду show ip route, переконатись, що з Лондона є маршрут на Сінгапур. На жаль у симулятора версії 6.0 Final beta проблеми з маршрутизацією.

Конфігуруйте локальні мережі філіалів як в табл. 6.1.

Перевірте повну конфігурацію за допомогою розширеної команди ping. Наприклад можемо з маршрутизатора в SanJose перевірити чи є зв’язок від філіального комп’ютера PCL у Лондоні до філіального комп’ютера PCS у Сінгапурі.

Все пінги повинні бути успішні. Зокрема між усіма PC.

 

Використання підінтерфейсів

На симуляторі версії 6 final beta не працює динамічна маршрутизація. Працюйте з симулятором версії 5.31.

Для поліпшення можливостей настроювання з’єднань мережні інженери спочатку використовують індивідуальні фізичні зв’язки між кожними двома філіалами. Однак загальна вартість проекту виявилась надмірною. Вирішено було використовувати підінтерфейси й Frame Relay. Це дозволяє створити окремий логічний канал між кожними двома філіалами. Кожен маршрутизатор має як і раніше одну фізичну лінію для з’єднання з Frame Relay, але для кожного послідовного інтерфейсу настроюється по два підінтерфейси. Стає можливим використання декількох каналів PVC для кожного фізичного інтерфейсу маршрутизатора.

Для цього слід створити нову конфігурацію заново. Перевантажити симулятор і завантажити колишню створену топологію (рис. 21.11). Настроїти на маршрутизаторах підінтерфейси відповідно рис. 21.13. Для кожного каналу PVC використайте окрему підмережу згідно з табл. 21.2.

 

 

Таблиця 6.2 - Підмережі мережі на рис. 21.13

PVC DLCI Підмережа
SanJose-London 102 - 201 192.168.192.0/24
SanJose-Singapoure 103 -301 192.168.193.0/24
London-Singapoure 203 - 302 192.168.194.0/24

Для цього використовувати команди.

На маршрутизаторі SanJose1:

Router(config)#hostname SanJose

SanJose(config)#interface serial 0

Рисунок 21.13 - Конфігурація мережі на рис. 21.11 з використанням підінтерфейсів

 

SanJose(config-if)#encapsulation frame-relay

SanJose1(config-if)#no shutdown

IP-адреса на весь інтерфейс не призначати. Адреси призначити на кожен підінтерфейс.

Інтерфейси Frame Relay можуть бути переведені або в режим точка-точка (point-to-point) або в режим багатоточка (multipoint). Конфігуруйте підінтерфейс точка-точка, використовуючи DLCI. Звичайною практикою є використання номера DLCI як номера підінтерфейс. Тоді легше визначити який канал PVC використає кожен підінтерфейс. Наприклад, підінтерфейс 0.103 використає DLCI 103:

SanJose(config-if)#interface s0.103 point-to-point

SanJose(config-subif)#ip address 192.168.193.1 255.255.255.0

SanJose(config-subif)#frame-relay interface-dlci 103

Ретельно введіть у симуляторі команду interface s0.103 point-to-point. Використайте табуляцію для видачі підказки після введення чергового слова команди.

Команда frame-relay interface-dlci використовується для визначення, який DLCI використає кожен підінтерфейс. Підінтерфейс точка-точка може використовувати тільки один DLCI. Якщо підінтерфейс для DLCI не визначено, то DLCI асоціюється з головним інтерфейсом s0.

Конфігуруйте підінтерфейс для DLCI 102:

SanJose(config)#interface s0.102 point-to-point

SanJose(config-subif)#ip address 192.168.192.1 255.255.255.0

SanJose(config-subif)#frame-relay interface-dlci 102

Конфігуруйте Ethernet0 і маршрутизацію

SanJose(config-if)#interface Ethernet0

SanJose(config-if)#ip address 192.168.0.1 255.255.255.0

SanJose(config-if)#exit

SanJose(config)#Router ospf 100

SanJose(config-Router)#network 192.168.0.0 0.0.255.255 area 1

Аналогічно, використовуючи рис. 21.13, конфігуруйте інші маршрутизатори.

Лондон

Router(config)#hostname London

London(config)#interface Serial0

London(config-if#encapsulation frame-relay

London(config-if)#no shutdown

London(config-if)#interface Serial0.201 point-to-point

London(config-subif)#ip address 192.168.192.2 255.255.255.0

London(config-subif)#frame-relay interface-dlci 201

London(config-subif)#interface Serial0.203 point-to-point

London(config-subif)#ip address 192.168.194.2 255.255.255.0

London(config-subif)#frame-relay interface-dlci 203

London(config-subif)#interface Ethernet0

London(config-if)#ip address 192.168.200.1 255.255.255.0

London(config-if)#no shutdown

London(config-if)#exit

London(config)#Router ospf 100

London(config-Router)#network 192.168.0.0 0.0.255.255 area 1

Сінгапур

Router(config)#hostname Singapore

Singapore(config)#interface Serial0

Singapore(config-if)#encapsulation frame-relay

Singapore(config-if)#no shutdown

Singapore(config-if)#interface Serial0.301 point-to-point

Singapore(config-subif)#ip address 192.168.193.4 255.255.255.0

Singapore(config-subif)#frame-relay interface-dlci 301

Singapore(config-subif)#interface Serial0.302 point-to-point

Singapore(config-subif)#ip address 192.168.194.4 255.255.255.0

Singapore(config-subif)#frame-relay interface-dlci 302

Singapore(config-subif)#interface Ethernet0

Singapore(config-if)#ip address 192.168.232.1 255.255.255.0

Singapore(config-if)#no shutdown

Singapore(config-if)#exit

Singapore(config)#Router ospf 100

Singapore(config-Router)#network 192.168.0.0 0.0.255.255 area 1

Перевірити на кожному маршрутизаторі статус PVC командою show frame-relay pvc. Команда show frame-relay map у випадку підінтерфейсів не дає відображення DLCI на IP-адресу. Кожен підінтерфейс розглядається як окремий фізичний інтерфейс для кожного каналу PVC. У цьому випадку кожен канал PVC містить тільки два хоста й немає потреби ідентифікувати наступний хоп.

Для перевірки правильності призначення адрес і для того, щоб переконатися, що усі підінтерфейси перебувають в активному стані використовувати команду show ip interface brief.Використовуючи команду show ip route, переконатися, що з Лондона є маршрут на Сінгапур

London#show ip route

Подивіться, що OSPF спрацював так, що Лондон має маршрут на мережу 192.168.232.0/24 Сінгапуру через Serial0.201 на адресу 192.168.192.1. Маршрут, через Serial0.203 на адресу 192.168.194.4 коротше. А як у вас? Питання оптимізації маршрутв тут не розглядаються.

Конфігуруйте локальні мережі філіалів відповідно табл. 21.1.

Перевірте повну конфігурацію за допомогою розширеної команди ping. Наприклад можете з маршрутизатора в SanJose перевірити чи є зв’язок від філіального комп’ютера PCL в Лондоні до філіальному комп’ютера PCS у Сінгапурі.

Усі пінги повинні бути успішні. Зокрема між усіма PC.

Топологія зірка

Трафік між Лондоном і Сінгапуром виявився незначним і було вирішено відмовитися від каналу PVC між ними й скористатися топологією зірка. Весь трафік між Лондоном і Сінгапуром буде проходити через SanJose.

Завантажте в дизайнер стару топологію. Натисніть в ній праву кнопку на хмарі Frame Relay, поміняйте DLCI відповідно рис. 21.14, тобто знищимо PVC між Лондоном і Сінгапуром.

Рисунок 21.14 - Топологія зірка

 

Використайте підінтерфейси в режимі point-to-point

SanJose:

Router(config)#hostname SanJose

SanJose(config)#interface Serial0

SanJose(config-if)#encapsulation frame-relay

SanJose(config-if)#no shutdown

SanJose(config-if)#interface Serial0.103 point-to-point

SanJose(config-subif)#ip address 192.168.193.1 255.255.255.0

SanJose(config-subif)#frame-relay interface-dlci 103

SanJose(config-subif)#interface Serial0.102 point-to-point

SanJose(config-subif)#ip address 192.168.192.1 255.255.255.0

SanJose(config-subif)#frame-relay interface-dlci 102

SanJose(config-subif)#interface Ethernet0

SanJose(config-if)#ip address 192.168.0.1 255.255.255.0

SanJose(config-if)#no shutdown

SanJose(config-if)#exit

SanJose(config)#Router ospf 100

SanJose(config-Router)#network 192.168.0.0 0.0.255.255 area 1

London:

Router(config)#hostname London

London(config)#interface Serial0

London (config-if)#encapsulation frame-relay

London (config-if)#no shutdown

London(config-if)#interface Serial0.201 point-to-point

London(config-subif)#ip address 192.168.192.2 255.255.255.0

London(config-subif)#frame-relay interface-dlci 201

London(config-subif)#interface Ethernet0

London(config-if)#ip address 192.168.200.1 255.255.255.0

London (config-if)#no shutdown

London (config-if)#exit

London (config)#Router ospf 100

London (config-Router)#network 192.168.0.0 0.0.255.255 area 1

Singapore:

Router(config)#hostname Singapore

Singapore (config)#interface Serial0

Singapore (config-if)#encapsulation frame-relay

Singapore (config-if)# no shutdown

Singapore (config-if)#interface Serial0.301 point-to-point

Singapore (config-subif)#ip address 192.168.193.4 255.255.255.0

Singapore (config-subif)#frame-relay interface-dlci 301

Singapore (config-subif)#interface Ethernet0

Singapore (config-if)#ip address 192.168.232.1 255.255.255.0

Singapore (config-if)#no shutdown

Singapore (config-if)#exit

Singapore (config)#Router ospf 100

Singapore (config-Router)#network 192.168.0.0 0.0.255.255 area 1

Введіть на усіх маршрутизаторах команди show ip interface brief і show interfaces serial0. Подивитесь стани інтерфейсів. Інтерфейси повинні бути активні (UP)

Введіть на обох маршрутизаторах команди show frame-relay pvcі show frame-relay lmi. Відмітити відсутність PVC між Лондоном і Сінгапуром. Для підінтерфейсів команда show frame-relay map не покаже відображення адреса DLCI. Використовувати show ip interface brief.

Використовуючи команду show ip route, переконайтеся, що з Лондона є маршрут на Сінгапур: London#show ip route

Подивиться, що Лондон має маршрут на адресу 192.168.192.1 через Serial0.201 на мережу 192.168.232.0/24 Сінгапуру.

Конфігуруйте локальні мережі філіалів відповідно табл. 6.1. Перевірити повну конфігурацію за допомогою розширеної команди ping. Наприклад з маршрутизатора в SanJose можете перевірити чи є зв’язок від філіального комп’ютера PCL у Лондоні до філіального комп’ютера PCS у Сінгапурі.

Усі пінги повинні бути успішні. Зокрема між усіма PC.

Подивиться шлях пакетів від філіального комп’ютера PCL у Лондоні до філіального комп’ютера PCS у Сінгапурі.

PCL#trace 192.168.232.2

Він лежить через маршрутизатор SanJose (192.168.192.1).

 

Завдання на роботу

+1. Для повнозв’язної топології чотирьох сайтів з локальними мережами (рис. 21.15) спроектуйте Frame Relay мережу з:

А) динамічним призначенням адрес;

В) підінтерфейсами.

Використайте протокол маршрутизації OSPF.

У розпорядженні є підмережа 10.v.0.0/16, де v – номер варіанта. Адреси мереж і інтерфейсів призначте самостійно.

Рисунок 21.15 - Топологія мережі для самостійної роботи

 

Зробіть скриншоти:

1. 4-х таблиць маршрутизацій для кожного маршрутизатора.

2. Команди розширеного пінга з будь-якого маршрутизатора для двох довільних пар комп’ютерів.

3. Результат виконання команди show frame-relay mapдля кожного маршрутизатора

2. Неповнозв’язні топології

У дизайнері, натиснувши праву кнопку на хмарі Frame Relay і вибравши пункт Set Frame Relay Parameters, можна відредагувати таблицю DLCI (рис. 21.16)

Рисунок 21.16 - Повнозв’язана топологія

 

і отримати різні неповнозв’язані топології. Розглянемо три: зірка (вилка) (рис. 21.17), літера П ) (рис. 21.18) і літера О (квадрат) (рис. 21.19).

Рисунок 21.17 - Топологія зірка (вилка)

 

Рисунок 21.18 - Топологія літера П

Рисунок 21.19 Топологія літера О (квадрат)

 

Спроектуйте Frame Relay мережу на рис. 21.15 з IP-адресами і топологією згідно свого варіанту у табл. 21.3.

Використовувати підінтерфейси згідно з пунктом 2.3 практичної частини. IP-адреси інтерфейсів і підінтерфейсів призначити самостійно. Використайте протокол маршрутизації OSPF.

Зробіть скріншоти:

1. 4 таблиці маршрутизацій для кожного маршрутизатора.

2. Команди розширеного пінга з будь-якого маршрутизатора для двох довільних пар комп’ютерів.

3. Результат виконання команди show frame-relay mapдля кожного маршрутизатора

Таблиця 21.3 - Варіанти завдань

Варіант Топологія Мережа
Рис. 6.17 1.1.0.0/16
Рис. 6.18 2.1.0.0/16
Рис. 6.19 3.1.0.0/16
Рис. 6.17 4.1.0.0/16
Рис. 6.18 5.1.0.0/16
Рис. 6.19 6.1.0.0/16
Рис. 6.17 7.1.0.0/16
Рис. 6.18 8.1.0.0/16
Рис. 6.19 9.1.0.0/16
Рис. 6.17 10.1.0.0/16
Рис. 6.18 11.1.0.0/16
Рис. 6.19 12.1.0.0/16

 

21.4 Контрольні запитання

1. Назвіть типи послідовних каналів зв’язку.

2. Де розташовується пристрій CSU/DSU і які функції воно виконує?

3. Що таке DTE і DCE?

4. Як DTE пов’язано з DCE?

5. Сформулюйте ідею мереж з комутацією пакетів МКП.

6. Що таке віртуальні ланцюга у МКП?

7. Назвіть типи МКП?

8. Які фізичні канали зв’язку використають МКП?

9. Як здійснюється доступ споживача до МКП?

10. Які технології передачі даних використаються у МКП?


ЛАБОРАТОРНА РОБОТА №22

 

Віртуальні локальні мережі VLAN

 

22.1 Мета роботи

 

Засвоїти принципи написання та використання підпрограм, використання стеку в мові Assembler.

 

22.2 Теоретичні відомості

Локальні мережі в цей час прийнято будувати на підставі технології комутуємого Ethernet. Прагнуть мінімізувати число використаних концентраторів (хабів - hab) і використовувати переважно комутатори (свічі - switch). У комутаторі між одержувачем і передавачем на час з’єднання утворюється віртуальний канал (virtual circuit) точка-точка. Така мережа може бути розглянута як сукупність незалежних пар одержувач-передавач, кожна з яких використає всю смугу пропущення. Комутатор дозволяє здійснювати паралельну передачу інформації. Комутація зменшує ймовірність переповнення в мережах Ethernet.

Якщо комутатору необхідно передати пакет на якийсь вхідний порт, і цей порт зайнятий, то пакет міститься в буферну пам’ять. Це дозволяє погодити швидкості передавачів і одержувачів пакетів.

Для відправки фрейму використаються два методи:

Відправлення із проміжним зберіганням (store-and-forward). Пакет повинен бути прийнято повністю перш ніж буде почате його відправлення.

Наскрізний метод (cut-through). Комутатор приймає початок пакета, зчитує в ньому адреса пункту призначення й починає відправляти пакет ще до його повного отримання.

Ethernet-комутатор з’ясовує МАС адреси пристроїв у мережі шляхом читання адрес джерел у прийнятих пакетах. Комутатор запам’ятовує у своїх внутрішніх таблицях інформацію на які порти й з яких МАС адрес приходять пакети. При підключенні до одного порту декількох пристроїв через концентратор (hub) у таблиці одному порту буде відповідати декілька MAC- адрес. Таблиці зберігаються в пам’яті, адресуємої за змістом (content-addressable memory, CAM): якщо адреса відправника відсутня у таблиці, то вона туди заноситься. Поряд з парами адреса-порт, у таблиці зберігається й мітка часу. Мітка часу у рядку таблиці змінюється при приході на комутатор пакета з такою же адресою. Якщо рядок таблиці не використався у певному періоді часу, то він знищується. Це дозволяє комутатору підтримувати правильний список адрес пристроїв для передачі пакетів.

Використовуючи CAM-таблицю, комутатор організує віртуальне з’єднання порту відправника з портом одержувача і передає пакет через це з’єднання.

Віртуальне з’єднання між портами комутатора зберігається протягом передачі одного пакета, тобто для кожного пакета віртуальне з’єднання організується заново на основі адреси одержувача, що містить в цьому пакеті.

Оскільки пакет передається тільки в той порт, до якого підключено адресат, інші пристрої підключені до комутатора, не отримать цей пакет.

У комутаторах Ethernet передача даних між будь-якими парами портів відбувається незалежно й для кожного віртуального з’єднання виділяється вся смуга каналу.

При передачі широкомовного пакета, у комутаторі утвориться «вєєр» каналів за принципом один до багатьох. Прикладами джерел широкомовного трафіка є ARP і маршрутизуючі протоколи.

Комутатори можна з’єднати один з одним. При цьому група попарно прямо або побічно зв’язаних комутаторів утворює один логічний комутатор з теоретично довільним числом портів. Тобто комутатори дозволяють створювати теоретично як завгодно більшу локальну мережу. Правильне з’єднання комутаторів, тобто вибір топології мережі становить одну з найважливіших завдань проектування локальних мереж.

Рекомендується здійснювати з’єднання комутаторів по шарам (рис. 22. 1): серверний шар, шар розподілу (distribution) і шар доступу (access). Рядові комп’ютери підключаються до слою доступу, а сервера до серверного слою.

Рисунок 22.1 - З’єднання комутаторів по шарам

 

Головною перешкодою для створення великих локальних мереж за допомогою одних тільки комутаторів є нелінійний ріст обсягу широкомовного трафіка з ростом числа пристроїв у мережі. При числі пристроїв у мережі більш, ніж 2000 (за іншими оцінками 500 – все залежить від топології мережі й класу розв’язуємих завдань) обсяг широкомовного трафіка різко зростає. Додавання нових пристроїв різко знижує продуктивність мережі.

Наприклад, якщо в мережі з декількох тисяч пристроїв один з комп’ютерів A уперше здійснює IP з’єднання з іншим комп’ютером B у цій мережі, то він повинен попередньо послати до усіх пристроїв мережі широкомовного ARP-запит для визначення MAC-адреси комп’ютера B.

Локальна мережа, створена за допомогою одних тільки комутаторів представляє один домен широкомовлення. Зменшити домен широкомовлення можна, фізично розділивши локальну мережу на незалежні підмережі (незалежні групи попарно зв’язаних комутаторів) і з’єднати їх у єдине ціле з використанням маршрутизаторів. Таке завдання можна вирішити тільки на етапі побудови мережі, але не в момент її експлуатації. Тут на допомогу приходять віртуальні локальні мережі VLAN (virtual local area network).

Віртуальна локальна мережа VLAN являє собою сукупність портів одного або більше комутаторів (рис. 22. 2).

Рисунок 22.2 - Віртуальна локальна мережа VLAN

 

VLAN дозволяють логічно розбити вхідну локальну мережу на кілька незалежних локальних мереж без фізичного обриву мережних з’єднань. Для цього адміністратор мережі повинен на кожному комутаторі призначити, які його порти ставляться до якої VLAN. За умовчанням усі порти комутатора ставляться до однієї VLAN з номером 1. Максимальне число VLAN у комутаторі дорівнює загальному числу його портів. Правильна розбивка локальної мережі на VLAN становить одну з найважливіших завдань проектування.

VLAN поводяться так само, як і фізично розділені локальні мережі. Тобто після розбивки мережі на VLAN отримаємо кілька локальних мереж, які далі необхідно об’єднати в єдине ціле за допомогою маршрутизації на третьому мережному рівні.

Концепція VLAN, крім рішення проблеми із широкомовним трафіком дає також ряд додаткових переваг: формування локальних мереж не по місцю розташування найближчого комутатора, а по приналежності комп’ютерів до рішення того або іншого виробничого завдання; створення мережі по типу потрибуємого обчислювального ресурсу й необхідної серверної послуги (файл-сервер, сервер баз даних). VLAN дозволяють вести різну політику безпеки для різних віртуальних мереж; переводити комп’ютер з однієї мережі в іншу без здійснення фізичного переміщення або перепідключення.

Для обміну інформацією про VLAN комутатори використають магістральний (транковий) протокол. Для здійснення обміну інформацією про VLAN між комутаторами необхідно створити магістральні порти. Магістральний порт це порт, використаний для передачі інформації про VLAN в інші мережні пристрої, приєднані до цього порту. Звичайні порти не рекламують інформацію про VLAN, але будь-який порт може бути настроєний для прийому/передачі інформації про VLAN. Необхідно активізувати магістральний протокол на потрібних портах, тому що він видалений за умовчанням.

Порт комутатора працює або в режимі доступу або в магістральному режимі. Відповідно зв’язок (link), приєднаний до порту є або зв’язком доступу або магістральним зв’язком. У режимі доступу порт належить тільки однієї VLAN. Порт зв’язку доступу приєднується до кінцевого пристрою: ПК, робочої станції, серверу, хабу. Фрейми, що проходять через порт доступу, є звичайними Ethernet фреймами.

Магістральні зв’язки здатні підтримувати декілька VLAN. VLAN на різних комутаторах зв’язуються через магістральний протокол. Магістральні порти не належать певної VLAN і використаються для приєднання до інших комутаторів, маршрутизаторів або серверів, що мають мережні адаптери з можливістю для підключення до багатьох VLAN.

Магістралі можуть розширити VLAN по усій мережі. Для магістральних цілей призначають високошвидкісні порти комутаторів: Gigabit Ethernet и 10Gigabit .



Последнее изменение этой страницы: 2016-04-18; Нарушение авторского права страницы; Мы поможем в написании вашей работы!

infopedia.su Все материалы представленные на сайте исключительно с целью ознакомления читателями и не преследуют коммерческих целей или нарушение авторских прав. Обратная связь - 3.231.166.56 (0.064 с.)