ТОП 10:

Тема № 41. Основные операторы циклов и ветвления



Вопрос № 195:При начальном значении X=15 по окончании работы программы

 

S:=0;

N:=1;

пока (S+N)<X

нц

S:=S+N;

N:=N+1;

кц;

вывод S;

 

будет выведено ...

Варианты ответов:(выберите один правильный ответ, время 2 мин)

1. 5

2. 21

3. 10

4. 15

 

 

Вопрос № 196:Данная программа

 

если A<B то

если C<A то вывод C

иначе вывод A

все

иначе

если B<C то вывод В

иначе вывод C;

все

все

выводит ...

Варианты ответов:(выберите один правильный ответ, время 2 мин)

1. числа A, B, C в порядке возрастания их значений

2. минимальное среди трех чисел A, B, C

3. числа A, B, C в порядке убывания их значений

4. максимальное среди трех чисел A, B, C

 

 

Вопрос № 197:Задан фрагмент алгоритма, в котором пропущено условие:

 

если X>Y то A=X-Y

иначе A=Y-X

Все

если _______ то A=A*A

иначе A=A*2

Все

Вставьте условие так, чтобы при X=-3, Y=4 в результате выполнения алгоритма A=14.

Варианты ответов:(выберите один правильный ответ, время 2 мин)

1. A>X

2. A>Y

3. A<X

4. A>0

 

 

Вопрос № 198:После выполнения фрагмента алгоритма

 

k := 0

нц для i от 1 до 5

нц для j от 1 до i + 1

k := k + 1

кц

кц

вывод k

 

значение переменной k будет равно ...

Варианты ответов:(выберите один правильный ответ, время 2 мин)

1. 25

2. 10

3. 20

4. 21

 

 

Вопрос № 199:Значение переменной z после выполнения фрагмента алгоритма

 

x := -1; y := 1; z = 0

если x < 0

то

если y > 0

то z := y + 1

иначе z := y + 2

все

если z <> 0

то z := z + 1

все

все

вывод z

 

равно ...

Варианты ответов:(выберите один правильный ответ, время 2 мин)

1. 1

2. 2

3. 10

4. 3

 

 

Тема № 42. Типовые алгоритмы

Вопрос № 200:Дан массив целых чисел {Xi}, i=1,2,…N, N=10. Данная программа

 

K=0;

нц для i:=1 до n-1

если x[i]=x[i+1] то k:=k+1;

кц;

вывод (k);

 

находит …

Варианты ответов:(выберите один правильный ответ, время 2 мин)

1. индексы несовпадающих элементов

2. индексы одинаковых элементов массива

3. количество положительных элементов массива

4. количество пар соседних одинаковых элементов

 

 

Вопрос № 201:Дан массив целых чисел {Xi}, i=1,2,…N, N=10. Данная программа выводит…

 

m:=x[n];

нц для i:=1 до n-1

если x[i]>m то m:=x[i];

кц;

вывод (m);

Варианты ответов:(выберите один правильный ответ, время 2 мин)

1. все максимальные элементы массива

2. максимальный элемент массива

3. количество минимальных элементов массива

4. минимальный элемент массива

 

 

Вопрос № 202:Дан массив целых чисел {Xi}, i=1,2,…N, N=10. Вставьте пропущенный фрагмент в программу вычисления суммы отрицательных элементов массива

 

s:=0;

нц для i:=1 до n

если x[i]<0 то ________;

кц;

Варианты ответов:(выберите один правильный ответ, время 2 мин)

1. X[I]:=S+X[I]

2. S:=X[I]

3. S:=S+X[I]

4. S:=S+1

 

 

Вопрос № 203:Дана матрица: A= . В результате выполнения алгоритма:

алг «вычисление значения переменной m»

m= a1,1

цикл по i от 1 до 3

цикл по j от 1 до 3

если (ai,j> m), то m= ai,j

кц по j

кц по i

вывод m

значение переменной m будет равно числу …

Варианты ответов:(выберите один правильный ответ, время 2 мин)

1. 11

2. 4

3. 1

4. 9

 

 

Вопрос № 204:Дана матрица: A= . В результате выполнения алгоритма:

алг «вычисление значения переменной m»

m= a1,1 ; k=1; n=1

цикл по i от 1 до 3

цикл по j от 1 до 3

если (ai,j> m), то

Начало

m= ai,j; k=i; n=j

Конец

кц по j

кц по i

вывод k, n

значения переменных k, n будут равны соответственно числам …

Варианты ответов:(выберите один правильный ответ, время 2 мин)

1. 1,3

2. 1,1

3. 3,1

4. 2,3

 

 

Тема № 43. Рекурсивные алгоритмы

Вопрос № 205:По окончании работы программы будет выведено ...

 

Функция F (арг цел X) : рез цел

Нач

если X <= 1

то F := 1

иначе F := F (X – 2) + 3

все

Кон

Нач

А := F(3)

вывод А

Кон

Варианты ответов:(выберите один правильный ответ, время 2 мин)

1. 6

2. 7

3. 1

4. 4

 

 

Вопрос № 206:По окончании работы программы будет выведено ...

 

Функция F (арг цел X) : рез цел

Нач

если X < 1

то F := 2

иначе F := F (X – 2) + 3

все

Кон

Нач

А := F(1)

вывод А

Кон

Варианты ответов:(выберите один правильный ответ, время 2 мин)

1. 5

2. 2

3. 6

4. 3

 

 

Вопрос № 207:По окончании работы программы

 

ПРОГРАММА 1000011

функция C(K,X);

Начать функцию

если K>1 то С:=C(K-1,X)*X;

если K=1 то C=X;

если K=0 то C:=1;

Конец функции

НАЧАТЬ ПРОГРАММУ

вывод C(3,2);

КОНЕЦ ПРОГРАММЫ

 

будет выведено ...

Варианты ответов:(выберите один правильный ответ, время 2 мин)

1. 8

2. 16

3. 1

4. 4

 

 

Вопрос № 208:В представленной рекурсивной подпрограмме

 

функция S(K);

Начать функцию

если K>5 то

S:=S(K-1)+K

иначе S:=0;

Все

Конец функции

при вызове функции S с параметром 7: S(7) – будет возвращено значение ...

Варианты ответов:(выберите один правильный ответ, время 2 мин)

1. 15

2. 18

3. 7

4. 13

 

 

Вопрос № 209:Обращение подпрограммы к самой себе при организации вычислений, это

Варианты ответов:(выберите один правильный ответ, время 2 мин)

1. рекурсивные вычисления

2. цикл.

3. бинарные вычисления

4. реляционное исчисление

 

 







Последнее изменение этой страницы: 2016-12-10; Нарушение авторского права страницы

infopedia.su Все материалы представленные на сайте исключительно с целью ознакомления читателями и не преследуют коммерческих целей или нарушение авторских прав. Обратная связь - 3.209.10.183 (0.012 с.)