A. способом соединения узлов сети каналами связи


 

16. Схема соединений узлов сети называется ______________ сети.

A. топологией

 

17. Топология сети _____________ НЕ ЯВЛЯЕТСЯ базовой.

A. в виде снежинки

 

Тема 19. Сетевой сервис и сетевые стандарты.

 

  1. Групповая дискуссия в Интернете называется…

A. телеконференция

 

  1. Гиперссылкой в Web-документе является…

A. объект, содержащий адрес Web-страницы или файла

 

  1. HTTP – это…

A. имя протокола сети, обслуживающего прием и передачу гипертекста

 

  1. FTP - сервер – это компьютер, на котором...

A. содержатся файлы, предназначенные для открытого доступа

 

5. Информационная или рекламная рассылка, автоматически рассылаемая по списку, без предварительной подписки называется…

A. спамом

 

  1. Дополните фразу для получения верного утверждения: "IP-адрес используется для ...

a. однозначного определения компьютера в сети

 

  1. Доменом нижнего уровня в адресе

Peter.student.university.edu

является…

A. Peter.

 

  1. Доменом верхнего уровня в адресе

Peter.student.university.edu

является…

A. edu

 

  1. Протокол FTP предназначен для...

A. передачи файлов

 

10. Задача установления соответствия между символьным именем узла сети Интернет и его IP-адресом решается с помощью службы _______ имен.

A. доменных

 

  1. Internet Explorer является…

A. встроенным браузером ОС Windows

 

  1. Приложение Internet Explorer позволяет…

A. загружать веб-страницы по протоколу HTTP и файлы по протоколу FTP

 

Темы 20. Алгоритмизация и программирование. Языки программирования высокого уровня. Основные алгоритмические конструкции. Базовые алгоритмы.

 

1. На рисунке представлен фрагмент алгоритма, имеющий ____________ структуру.

A. циклическую с постусловием

 

2. В результате выполнения фрагмента блок-схемы алгоритма

a и b примут значения …

a. a=2, b=2

 

3. В результате выполнения фрагмента блок-схемы алгоритма

X и Y примут значения …

a. X=3 , Y=4,5

 

4. Изображенный на рисунке фрагмент алгоритма

определяет ...

A. максимум из трех чисел

 

5. В результате выполнения алгоритма

значение переменной b будет равно…

A. 5

 

6. Следующий фрагмент программы

ЕСЛИ Х < Y ТО

ЕСЛИ X < Z ТО M:= X

ИНАЧЕ M:= Z

ВСЕ

ИНАЧЕ

ЕСЛИ Y < Z ТО M:= Y

ИНАЧЕ M:= Z

ВСЕ

ВСЕ

вычисляет…

A. минимум из трех чисел

 

7. В результате выполнения алгоритма

алг «Вычисление значения переменной s»

s:=0

нц для k:=2 до 6

s:=s+k

кц

вывод s

значение переменной s будет равно числу …

A. 20

 

8. Инструкция 3 в приведенном операторе

если условие 1

то инструкция 1

иначе если условие 2 то инструкция 2

иначе инструкция 3

конец если

выполняется, если …

A. условие 1 ложно, условие 2 ложно

 

9. Если задан фрагмент алгоритма

если a>b, то a=a-b, иначе b=b-a

если a>b, то a=a-b, иначе b=b-a

напечатать a, b

то при заданных начальных условиях a = 375; b=425 после выполнения алгоритма переменные a и b соответственно примут значения …

a. a = 325; b = 50

 

10. Если задан фрагмент алгоритма

если a > b

то a = a - b, b = b - a

иначе b = b - a, a = a – b

все

напечатать a, b

то при заданных начальных условиях a = 5; b = - 4 после выполнения алгоритма переменные a и b соответственно примут значения …

a. a = 9; b= - 13

 

11. В результате работы алгоритма

Y := X + 5

X := Y

Y := X + Y

вывод Y

переменная Y приняла значение 14. До начала работы алгоритма значением переменной X являлось число…

A. 2

 

 

12. В результате работы алгоритма

Y := X - 1

X := Y +2

Y := X + Y

вывод Y

переменная Y приняла значение 10. До начала работы алгоритма значением переменной X являлось число…

A. 5

 

13. В результате выполнения фрагмента блок-схемы алгоритма

ввод Х, А, В, С

Y := X^3+B*C+A

вывод Y

при вводе значений Х, А, В, С, равных: 3, 2048, 2047 и -1 соответственно, значение Y будет равно…

A. 28

 

14. Значение Y в результате выполнения алгоритма

ввод А, В, С, Х

Y := (A+C)/B*X

вывод Y

при вводе значений: 10, 3, 14, 4, будет равно…

A. 32

 

15. Круглые скобки для определения порядка выполнения вычислений выражения ab*2+3.456 y правильно расставлены в выражении …

a. ((a^b)*2)+(3.456*y)

 

16. Задан фрагмент алгоритма:

1) если a<b, то с=b-a, иначе c=2*(a-b)

2) d=0

3) пока c>a выполнить действия d=d+1, с=с-1

В результате выполнения данного алгоритма с начальными значениями a=8, b=3, переменные c и d примут значения...

a. c=8, d=2

 

17. Значение переменной d после выполнения фрагмента алгоритма

k := 30

выбор

| при div ( k, 12 ) = 2: d := k;

| при mod( k, 12 ) < 5: d := 2;

| при mod( k, 12 ) > 9: d := 3;

| иначе d := 1;

все

равно...

A. 30

 

18. После выполнения алгоритма

b:= 10

d:= 50

нц пока d >= b

| d := d - b

кц

значение переменной d равно...

A. 0

 

19. После выполнения алгоритма

b:= 10

d:= 40

нц пока d >= b

| d := d - b

кц

значение переменной d равно...

A. 0

 

20. В представленном фрагменте программы

b:= 10

d:= 50

нц пока d >= b

| d := d - b

кц

тело цикла выполнится...

A. 5 раз

 

21. Проектирование программ путем последовательного разбиения большой задачи на меньшие подзадачи соответствует…









Последнее изменение этой страницы: 2016-04-18; Нарушение авторского права страницы

infopedia.su не принадлежат авторские права, размещенных материалов. Все права принадлежать их авторам. Обратная связь